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 1 - Open Pro 
• Use the shortcut on your desktop or launch the program from Geotec\Bin folder.  

 2 – Enter your license identification (LID) provided by Sobek 
• For a trial license, the LID starts with T. 

• For an individual license, the LID starts with W. 

• For a removable license, the LID starts with R. 

• For a network license, the LID starts with N. 

 3 – License and software information 
• From the menu bar, use Help > License. 

The window shows information about the license used. 

• From the menu bar, use Help > About. 
The window shows information about the Geotec version installed. 
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Pro is used to produce profile views of borehole data. With Pro, you can create cross-sections to view geotechnical, environmental 
or geomechanics properties of boreholes projected on an outline. The production of profile views includes the following steps, 
without necessarily following the order below. 

 Enter borehole data and location 
Profile views are produced with borehole data available in the corporate database.  See the Tutorial on Log for basic information 
about the definitions, graphic interface, characteristics of entry forms and data entry.  
 
To create a profile view, the location of boreholes must be defined, in terms of coordinates or chainage along an axis.  

 Create an axis (outline) 
The axis is the outline onto which the borings are projected. It has a minimum of two points.  It does not have to go through the 
borings. Pro calculates the projection and indicates the offset perpendicular to the axis.  

 See all data in PROFILE 
Once an axis (outline) is created, simply retrieve it via a query for the cross-section to the displayed. Round the limits of the X and Y 
axes of the PROFILE graph to make sure to see all available data. 

 Edit the options 
Several display options of geotechnical properties are available to adjust the look of the presentation. These options are saved in the 
style file, which is a customizable graphic output, independent from projects.  

 Define the X and Y scales 
The scales of the profile view can be optimized by Pro, or fixed by the user. The scale is typically expressed as the ratio of the 
measurement on the profile view over the real measurement in the field, for example 1:1000.  

 Edit the graphic presentation 
The look of the presentation is saved in the style file, which can be reused for any project. The page format can be selected, as well 
as the columns to display for each boring, including their width, formatting and X-axis, if needed.  

 Print and export to DXF 
The graphic report can be printed on paper or PDF, or exported to DXF.  

 
 

      Pro can be used in English 
or in French. Change the 
language via the Style menu. 
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 Define the coordinate system 
Geotec supports the UTM and MTM coordinate systems. It is important to define the coordinate system used to correctly locate the 
borings along the georeferenced outline.  

• Open the Site entry form via button  of the horizontal toolbar.  

• Retrieve the site via a query with buttons  → site no. →  or [F7] → site no. → [F8]  

• In the Location tab, make sure that the coordinate system, NAD and zone are defined.  

Then, Geotec can calculate the longitudes and latitudes of the borings based on their X and Y coordinates, or vice-versa. The location 

of the site can also be calculated as the average of its borings locations via button . 

 1a - Enter the X, Y and Z coordinates of the borings 
Pro uses the X, Y and Z coordinates of the borings to locate them on the profile view.  

• Open the Boring entry form via button  of the 
horizontal toolbar.  

• Retrieve the site’s borings via a query with buttons  

 → site no. →  or [F7] → site no. → [F8]  

• Enter the natural ground elevation (Z) as well as 
the Easting and Northing.  

• If the coordinate system is defined (see previous 
bullet point), the longitude and latitude will be 
automatically calculated. You can also launch the 

calculation with button .   

 1b - Enter the chainage, offset and 
associated axis (outline) 

If coordinates are not taken, Pro can create the profile view along the axis, with the borings chainage and offset from the axis.  

• Open the Boring entry form via button  of the horizontal toolbar.  

• Retrieve the site’s borings via a query with buttons   → site no. →  or [F7] → site no. → [F8]  

• Define the associated axis number, the chainage of the boring and its offset to the axis.  

 2 - Enter the dip and azimuth 
For inclined borings, indicate the dip and azimuth. The values are taken into account in the projection.  
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 Definition of axis (outline) 
The axis is the outline onto which the borings are projected. It has a minimum of two points.  It does not have to go through the 
borings. Pro calculates the projection and indicates the offset perpendicular to the axis.  
 
The axis can be created by entering its implementation points or by importing its points from an Excel file of CSV extension. It can 
also be created interactively in Google Maps or in the plan view.  

1- Define in the entry form or import points  
• Open the Axis entry form via button  of the horizontal toolbar.  

• In New mode, select the site of the axis. The list shows all sites defined in the SITE table. 

• Enter the axis number. It can have up to 20 characters with numbers, letters and symbols - _ ( ) . 
Note: The site-axis combination must be unique.  

• Enter other relevant data such as its type, state, 
location, etc.  

• In the Survey points tab, enter the point index and 
the X and Y coordinates.  

• The coordinates are entered according to the 
coordinate system, NAD and zone defined in 
the site.  

• The index determines if the borings are left or 
right of the axis, from the point of view of an 
observer on the smallest index looking to the 
other end. Their position is shown by an arrow 
up or down, respectively, in the profile view. 

• For implementation points, you can add a 
radius of curvature for the outline.  

You can import survey points of an axis via the Import 

External Data (CSV) button  of the toolbar. The CSV file must contain, for each point, at least its SITE_NO, AXIS_NO, I, X and Y. 
There is not maximum number of points per axis.  

2- Create interactively in Google Maps  
• Open the Google Maps entry form via button  

of the horizontal toolbar. 

• Move the map, or use the drop-down list to Center 
the map on a specific site.  
Note: To be in the list, the site must have a 
longitude and latitude, which can be calculated in 

Geotec via button  of the site entry form. 

• Right-click and choose Create an Axis. The cursor 

changes to .  

• Left-click each point of the axis.  

• When the last point is defined, right-click and 
select Terminate.  

• The axis entry form opens and shows the 
coordinates of each point clicked. 
Note: The axis points are converted to geodesic 
coordinates based on the coordinate system 
defined for the site of the axis.  

• Enter the axis number and any other relevant 
information.  

3- Create interactively in the plan view 
If a plan view is displayed in Pro and an axis is already retrieved, you can create a new axis via the plan view.  

• Right-click in the plan view and choose Create an Axis. The cursor changes to .  

• Left-click each point of the axis.  

• When the last point is defined, right-click and select Terminate.  
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• The axis entry form opens and shows the coordinates of each point clicked.  
Note: The axis points are shown in the coordinate system defined for the site of the axis.  

• Enter the axis number and any other relevant information. 

4- Modify interactively an axis 
In Google Maps and in the plan view, you can modify an existing axis (outline) whose value in the State field is ‘P’ (planned).  
To add a point: 

• Right-click on the axis and choose Add an Axis Point.  

• Left-click at the location of the new point; it will be added between the two points closest to the cursor.  

• Add another point or right-click and choose Terminate.  
To move a point: 

• Place the cursor on the axis point.  

• Left-click, hold and move the point to the desired location.  
To delete a point:  

• Right-click on the axis point and choose Delete this Axis Point. 
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 Query to retrieve the axis  
Once an axis (outline) is created, simply retrieve it via a query for the cross-section to the displayed.  

• Click  from the toolbar or [F7] to open the Axis 
entry form directly in Query mode.  

• Enter the criteria to filter the records, for example 
the site number and/or axis number.  

• Execute the query by clicking  in the toolbar, or 
[F8], or Query > Execute. 

 
The query retrieves all records corresponding to the 
specified criteria. If more than one axis is retrieved, 
the 1st is shown in PROFILE_1, the 2nd in PROFILE_2 (if 
it exists), etc.  
 
If no record corresponds, the entry form returns in 
New mode (to insert).  

  Round the limits of the axes 
Pro displays the borings around the axis retrieved, depending on the retrieval distance (see Options In Pro), between the minimum 
and maximum X and Y limits of the profile.  
 
Round the limits of the X and Y axes of the PROFILE 
graph to make sure to see all available data. 
 
To make sure to see all available data, it is suggested 
to round the limits of the X and Y axes of the PROFILE 
graph. Pro will then optimize the display based on the 
borings data and space available on the page.  

• Use  in the vertical toolbar, or Style > Axes. 

• Select graph PROFILE_1 in the drop-down list, if 
not already selected.  

• Go to X axis tab. 

• For the Min and Max axis limits, choose Rounded.  

• Do the same for the Y axis.  
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OPTIONS IN PRO 

Several display options of geotechnical properties are available to adjust the look of the presentation. These options are saved in the style 
file, which is a customizable graphic output, independent from projects.  

Click  in the horizontal toolbar of Pro, or Style > Options. 

Selection of axes and borings 
This section is used to customize the borings to retrieve.  

• Choose to display the profile of one axis only (the first retrieved) or of several (all those retrieved). To show several axes, you must also 
have several graphs PROFILE_1, PROFILE_2, etc. in the style.  

• Choose to display the borings from the current site (same site as the axis), or of all nearby sites, in which case the borings close to the 
axis will be displayed, no matter their site.  

• By checking retrieve only borings close to the current axis, Pro retrieves only the borings located in a rectangular boundary around the 
axis, based on the distance specified in the next field. This avoids using too much memory.  
To retrieve a cross-section whose borings are located by a chainage and an offset (see section 1b on page 2):  select Current site and do 
not check the option Retrieve only borings close to current axis. 

• Specify the maximum detection distance between the boring and the axis, beyond which the borings are not represented on the profile 
view. This distance (offset) is calculated perpendicular to the axis and on both sides.  

• Specify the minimum offset between the boring and the axis, beyond which the offset will be shown in the graphic report next to the 
boring identifier. If the boring is located at a lesser distance than the minimum offset, its offset will not be displayed.  

• If necessary, specify a spacing between the borings, in millimeters, to displayed them equidistant from each other.  

Identifier of borings 
This section is used to customize the 
display of the boring numbers and their 
offset to the axis on the profile views. 

• Choose to display the identifier of 
borings as text (number only), with a 
significant marker (symbol) or in a 
square or round box and specify its 
dimensions.  

• Choose to display the identifier at a 
distance relative to the top of each 
boring or of the graph.  

• Modify the formatting of the boring 
identifier and of the offset via the big 
Attributes buttons.  

Presentation of axis points 
and seismic lines 

This section is used to customize the 
display of the axis points on the cross-sections.  

• Check the desired items to display them.  

• Indicate the distance between the symbol and the top of the graph. A negative distance puts the symbol inside the graph.  

• Modify the formatting of the items via the big Attributes buttons.  

• If seismic test data is present for the axis (see the axis definition), the measured velocities can be displayed under the seismic profile, and 
the profile is interrupted if the spacing between 2 geophones is greater than the spacing specified in the options.  

Display on plan view 
This section is used to customize the display in the plan view, if visible on the graphic report.  

• Display the site map specified in field FILE_NAME of the SITE table. This file is cartographic (.dxf, .sit, .ctr – see the Site module). If a map 
is displayed, you can use its domain for the plan view.  

• Check to rotate the domain to follow the current axis for Pro to adjust the orientation of the plan view so that the axis follows the profile 
view. Otherwise, the plan view is oriented with North up.  

• Choose to display in the plan view only the borings projected on the profile view, or all borings retrieved (therefore including those 
unchecked by the user or too far from the axis to be projected).  
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The scales of the profile view can be optimized by Pro, or fixed by the user. The scale is expressed as the ratio of the measurement 
on the profile view over the real measurement in the field, for example 1:1000.  
 
To fix a scale, use the ratio of the width in mm of the PROFILE graph to the length of the real outline.  

 Display the scale calculated by Pro 
Pro calculates the current scale, which can be display on the graphic output.   

• Go to Object mode with  

• Add a text or a text zone via the horizontal toolbar. 

• As text, enter keyword $$scale_hor_1 for the horizontal scale of profile 1, $$scale_ver_1 for the vertical scale of profile 1, etc. 
The keywords are expressed as measurement on field / measurement on plan. Simply add 1/ or 1: in front.  

 Fix the measurement on plan in X 
The dimensions (in mm) of the PROFILE graph are 
fixed in the style file. The positions in mm are 
calculated from the bottom left of the page.  
 
The maximum space available is indicated in the Page 
row of the table, and depends on the page dimensions 
(Letter, Legal, Ledger, A0, etc.) 

• Click  in the horizontal toolbar, or Style > 
Graphs. 

• For PROFILE_1 graph, adjust the left position and 
width of the graph. It is the width that is used for 
the X scale.  

• Do the same for the bottom position and the 
height.  

 Fix the measurement on field in X 
To have a specific scale, fix the measurement of the 
axis (outline), in other words the difference between 
the maximum and minimum limits of the axis.  

• Click  in the horizontal toolbar, or Style > Axes. 

• Select graph PROFILE_1 in the drop-down list, if 
not already selected.  

• Go to X axis tab. 

• For the Min and Max axis limits, choose Fixed and 
indicate the values. Delta (difference) is calculated 
by Pro.  

 Fix the distortion in Y 
To fix the scale in Y, it is recommended to impose a distortion.  

• Click  in the horizontal toolbar, or Style > Axes. 

• Select graph PROFILE_1 in the drop-down list, if not already selected.  

• Go to Y axis tab. 

• For the Min and Max axis limits, choose Rounded.  

• For Distortion D/X, choose Fixed and enter the value (ex: 5).  

 Calculation of above example 
The scale in X is calculated as the measurement on plan (width of PROFILE_1 graph) over the length of the outline (delta in X), or: 
400 mm / 800 m = 1 mm / 2 m = 1 / 2000 
 
The scale in Y is calculated as the scale in X multiplied by the distortion, or: 
1 / 2000 x 5 = 1 / 400 
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The look of the presentation is saved in the style file, which can be reused for any project. The page format can be selected, as well 
as the columns to display for each boring, including their width, formatting and X-axis, if needed.  

 Page format 
The page dimensions can be modified. It is recommended to save a style file per page format, for the dimensions of the graphs to be 
already adjusted.  

• Click  in the horizontal toolbar, or Style > Page. 

• At the top right, select a standard format in the drop-down list (letter, legal, tabloid, A0, A1, etc.) or enter the desired 
dimensions.  

• When printing, it will be important to configure the 
printer with the same standard format.  

 

  Columns of properties 
Any property of borings as a function of depth can be 
displayed in a column.  

• Click  in the horizontal toolbar, or Style > Graphs. 

• Modify or copy an existing row and enter a negative 
number in #P.  

• In the Name cell, choose the table from which you 
want to display data (from the DB). 

• Indicate the left and right or width in millimeters 
relative to the center of the boring (« 0 »). A 
negative value means left of center.  

 

 Formatting of columns 
• Click Configure in the graphs window, or  in the 

horizontal toolbar, or Style > Legend and curves. 

• Select the column to edit in the drop-down list, if 
not already selected.  

• Modify or copy an existing row.  

• In the Name cell, choose the field from which you 
want to display data (from the DB). 

• Modify the type of display (Text, Point, Histogram, 
etc.). The Default type is managed by Geotec. 

• Modify the formatting via the Attributes button 
under Delete.   

 

 Formatting of columns axes 
• Click Axes in the graphs window, or  in the 

horizontal toolbar, or Style > Axes. 

• Select the column to edit in the drop-down list, if not 
already selected.  

• Go to X axis tab and modify the desired elements.  

• Axis type 

• Minimum and maximum limits 

• Primary and secondary divisions 

• Axis line, title, labels, grids and tick marks  
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The graphic report can be printed on paper or PDF, or exported to DXF.  

 Printing on paper or PDF 
In both cases, you must configure the printer.  

• Do the query to retrieve the profile view(s).  

• Go to File > Printer Setup. 

• Choose the paper or PDF printer installed on your workstation. We 
recommend Adobe PDF.  

• Select the correct paper size and click OK.  

• Go to File > Print. 

• Uncheck Print on file (the bottom section will be disabled). 

• Click OK.  

• If printing on PDF printer, the file name suggested is SiteNo_AxisNo.pdf. 

 Exporting to DXF 
The graphic report can be exported to DXF format for AutoCAD.  

• Do the query to retrieve the profile view(s).  

• Go to File > Print. 

• Check Print on file and file .DXF. 

• Indicate a line width of 0 for AutoCAD.  

• Check Save as blocks for each boring to be a unique bloc in AutoCAD.  

• Check Group all blocks for all blocks (borings) to be grouped as one in AutoCAD.  

• Click OK.  

• The file name suggested is SiteNo_AxisNo.dxf. 
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CONTACT US 
 

At Sobek, we are committed to providing a technical support that exceeds your expectations. 
Our team of specialists will gladly answer your questions or comments. 

 
Technical Support and Training 
support@sobek-technologies.com 

 

Sales and General Information 
Geneviève Lessard: genevieve@sobek-technologies.com or 514 285-4873 

 
Geotechnical Development 

Ghislain Lessard: lessard@sobek-technologies.com or 514 285-5511 
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