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 1 – Open Log 
• Use the shortcut on your desktop or launch the program from Geotec\Bin folder.  

 2 – Enter your license identification (LID) provided by Sobek 
• For a trial license, the LID starts with T. 

• For an individual license, the LID starts with W. 

• For a removable license, the LID starts with R. 

• For a network license, the LID starts with N. 

 3 – License and software information 
• From the menu bar, use Help > License. 

The window shows information about the license used. 

• From the menu bar, use Help > About. 
The window shows information about the Geotec version installed. 
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 Database (DB) 
• This is the file in which data is saved. The database contains all sites, borings, samples, etc.  Centralize all your data in one 

corporate database. 

• There are four database management systems (DBMS) supported by Geotec: Microsoft Access, SQL Server, SQLite and Oracle. 

• The Geotec databases have a normalized structure of tables, fields and relationships between the tables – no table or field 
definition is done by the user. The databases are created via the DBM module. 

• The database structure can be in English or in French. It remains compatible with all style files.  

 Data Hierarchy 
• The site corresponds to the mandate for which borings are being carried out. It is defined by a unique number in the database. 

• The boring is defined by its number and its site number. The site-boring combination must be unique in the database.  

• Samples, layers, in-situ tests and other data will all be linked to the boring. 

• Lab tests are defined by their site-boring-sample combination which must be unique in the database. 

 

 Style file 
• This is the look of the presentation.  The style file is a customizable graphic output independent from projects.  

• Graphs, columns and objects are linked to specific fields in the database and are presented with the user-defined display. 

 Markers and patterns file 
• A default markers file and a default patterns file are installed with Geotec.  

• Markers are point symbols used for curves, water levels, etc. 

• Patterns are fill symbols used to represent soils and rocks.  

 Entry forms 
• Entry forms are integrated in all modules of Geotec to enter, modify, delete and view data. Entry forms include calculations, 

validations, default values and automations. 

• Entry forms are used to retrieve data based on various criteria via the Query mode.   

 

 

SITE  

BORING  

SAMPLE  

LAB TESTS

RUN ROCK JOINTS STRATIGRAPHY PIEZOMETER IN SITU TESTS

AXIS  

AXIS_PI AXIS_PROFILE

CLIENT 

PROJECT CONTRACT 

      Log can be used in English 
or in French. Change the 
language via the Style menu.  
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INTERFACE OVERVIEW: MENUS AND TOOLBARS 

Horizontal toolbar 
Most buttons are linked to the data. 

Vertical toolbar 
Most buttons are linked to the presentation.  

 

 

 

 

 

 

 

 

 

 

 

 

 
To connect to a database 
File > Open DB and File > Connect DB  
 
To search for data through specific tools 
Data > Retrieval by 
 
To change the current log report 
Data > Record 
 
To open entry forms 
Data > Entry 
 
For more data tools 
Data menu 
 
To navigate pages of one boring report 
[Home], [Page Up], [Page Down], [End] 

 
File > Open Style  
File > Save Style 
 
 
 
View menu  
To change the zoom on screen 
 
 
 
Continuous zoom 
[Ctrl] + Left hold + move mouse 

 
Style menu 
To edit the style file 
(presentation) 
 
 
 
 
 
 
Style menu 
To view markers, patterns, 
preferences and object 
mode (presentation) 
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 1 – Connect to a database 
• Use  or File > Open Database to open an Access or db3 database.  

• Use  or File > Connect Database to connect to an SQL Server or  
Oracle database. 

• Enter the username, password and connection alias provided by your IT. 

• If you are doing a trial, open Geotec_tutorial.mdb in folder \Geotec\Access. 

• The title bar shows the software name and the connected database  
between brackets as [DBMS: File] (Database version - Language).  

 2 – Change the style file 
• A default style file should be opened.  To use a different presentation: 

Use  or File > Open Style to select another style file created via Log. 

 3 – Verify the markers and patterns file 
• A default markers file and patterns file should be opened.  Verify the files being used with: File > Recent Markers and  

File > Recent Patterns. 

 4 – Select a logo 
• Use File > Recent Logos and select a row to open your logo file. Make sure an image identified as $$logo exists (see OBJECTS on 

page 10). 

 5 – View the entry forms menu 
• Use Menu button  of the horizontal toolbar or Data > Entry > Entry Forms Menu. 

• A window opens, showing a button for each entry form, all grouped by data type. 

 6 – Enter your data 
• Follow the DATA HIERARCHY on page 1. 

 

      Include the connection string in your shortcut to 
automatically connect to the last database used. 
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 1 – Create a site  
• Use Site button of entry forms menu. 

• Or, use Site button  of horizontal toolbar. 

• Or, use Data > Entry > Site. 

 2 - Enter the Site No 
• The number must be unique in the database. 

• It can have up to 20 characters with numbers,  
letters and symbols - _ ( ) . 

 3 - Enter data for your project 
• Data are saved in SI units by default. 

• Enter the coordinate system, NAD and zone  
under Location tab to be able to calculate longitudes and latitudes of borings based on X and Y coordinates, or vice-versa. The 
location of your site can be calculated as the average of its boring locations.    

 4 – Save your site  
• Data is saved directly in the database. 

 

CHARACTERISTICS OF ENTRY FORMS 

 Title bar 
• The title bar indicates the table associated to the entry form.  

• The number of records retrieved through a query is indicated, as well as the position of the current one displayed. 

• The status is indicated: 
 New: inserting a new record 
 Saved: record saved in the database 
 Modified: record has been modified but not saved 

 Toolbar items and menus 
When an entry form is opened, the menu items change. They reflect actions specific to the entry forms. 

• Save changes: Use or Action > Save or [F10].  When going to the previous or next record, changes are automatically saved.  

• The boring report gets refreshed automatically when  is selected.  

• Perform database queries: Use    or Query menu or [F7] and [F8] (see QUERY AND DATA RETRIEVAL on page 8). 

• Navigate through records: Use      or Record > First to Record > Last or [Ctrl]+[Home] and [Ctrl]+[End].  

• Insert a new record: Use or Record > Insert or [F6]. 

• Delete current record: Use or Record > Delete or [Shift]+[F6]. It is not possible to delete a record if others depend on it hierarchically.  

• Duplicate current record: Use  or Record > Duplicate or [F6]+[F4].  

• Import External CSV files into the database: Use  or Action > Import Data. See page 9. 

• Export the current data retrieved to a CSV file: Use  or Action > Export Data. See page 9. 

• Launch calculations: Use .  The button is active when there is a calculation function in the entry form.  

• View shortcuts: Use  to see the list of shortcuts. 

 Display of current entry form 
Each entry form can be displayed 3 different ways, depending on user preference.  

• Use  or Display > Tab Form to view one record only with predefined tabs, and groups of labels and fields. 

• Use  or Display > Datasheet to view multiple records as rows and each field as a column. 

• Use  or Display > Columnar to view one record only with fields as rows. 

 Unit conversion 
Depths can be entered in meters or feet. Lengths can be entered in meters, feet or inches. 

• Use Display > Conversions to select the unit conversion for each entry form.  

• The values are converted and saved in SI units (by default) or in the unit system defined in the Site entry form. 

 

      Shortcuts: 
[F1]: View field 
information 
[F3]: Copy value from 
previous record 
[F4]: Copy previous record 
[F6]: Insert record 
[F7]: Enter query 
[F8]: Execute query 
[Ctrl]+[Q]: Cancel query 
[F9]: Open list 
[Esc]: Cancel or clear 
[Tab] or [Enter]: Go to 
next field 
[Ctrl]+[E]: Open text editor 
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CHARACTERISTICS OF ENTRY FORMS (continued) 

 Types of fields 
Background and text colors identify the types of fields.  

• Key fields (required) – turquoise. The combination of keys defines a unique record in the database. The records must be entered 
hierarchically.   Ex: a boring must be created before entering its samples.   

• Disabled fields – gray.  No values can be entered.  

• Fixed fields – green.  These values are calculated or used for calculations by Log but not saved in the database. 

• Calculated fields – orange.  These values are calculated by Log but can be modified and saved in the database. 

 Field information 
• Field structure is predefined by Geotec.  Use [F1] to open a pop-up with field information: NAME, TYPE, LENGTH and if REQUIRED.  

• Hover the mouse over any field or header to open a tooltip describing the field and its unit or format.  

 Double-click 
• Double-click in a key field (blue background, such as site no, boring no, sample no, etc.) to open the parent table on the current record. 

• Double-click in a field referring to another table to open that corresponding table (client no, contract no, etc.). 

• Double-click in other text fields to open the Lists table. 

 Drop-down lists 
Each text field can show a drop-down list, either showing values predefined in the Lists table of the database, or showing values existing in 
the database for the current field.  

 

EN
TE

R
 D

A
TA

 –
 C

R
EA

TE
 A

 B
O

R
IN

G
 

 1 - After creating the site, create  
a boring 

• Use the List of tables linked at the bottom of  
Site entry form. 

• Or, use Boring button  of horizontal toolbar. 

• Or, use Data > Entry > Boring. 

• Or, double-click in the header of the boring 
report. 

 2 - Select the Site No  
• The list shows all sites defined in SITE table. 

 3 - Enter the Boring No  
• The site – boring combination must be unique  

in the database. 

• It can have up to 20 characters with numbers,  
letters and symbols - _ ( ) .  

 4 - Enter data for your boring 
• The ground level is used to calculate elevations.  

• The dip and azimuth (Location) are used in calculations and projections if entered. 

• The total depth increments automatically as new data is entered in other tables. 

• The rock depth is set as the depth of the 1st rock strata. 

• The latitude and longitude are calculated from X and Y coordinates, or vice versa, if the coordinate system, NAD and zone are set 
for the Site.  

• A photo can be added to the report. The complete filename is entered in the management tab.  

   Google Maps 
• Open Google Maps in the horizontal toolbar of Log to locate sites and borings that have a longitude and latitude in the database. 

• Move around, zoom in or zoom out to view different locations. 

• Hover over an entity to see some information. 

• Right click on an entity to retrieve its properties or its complete boring report.  
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 1 – After creating the boring, add 
samples 

• Use the list of descriptive tables at the bottom  
of Boring entry form. 

• Or, use Sample button  of horizontal toolbar 

• Or, use Data > Entry > Sample.  

• Or, double-click in a sample column of the  
boring report. 

 2 - Select the Site No and  
Boring No 

• The lists show the sites and borings defined in  
BORING table. 

 3 – Edit the depth increment 
• The top depth is automatically suggested.  

• Without increment, the sampling is  
considered continuous.  

• With an increment, the suggested depth is the top depth of previous sample plus the increment.  

 4 – Use the same sampler or select the sample state 
• If the Same sampler box is checked, the state, type and length of the previous sample are copied for the new one.  

• Otherwise, select the sample state as remolded, intact, core or grab. 

• The type and length associated to the state are automatically entered.  

• Some fields are disabled depending on the state.  

 5 – Edit the sample number (if needed) 
• The No of the first sample is suggested as 1 and can be modified.  

• The number of the subsequent samples of the boring will be based on the  
previous sample (number and format).  

 6 - Enter data relevant to your sample 
• Enter the caliber, tube number, recovery, blow counts and / or RQD, depending on the sample state.  

• Enter lengths to calculate percentages. 

• Log calculates N = N2 + N3. 

 7 – Describe the sample 
• Describe the sample with the soil description matrix via  . 

 8 – Add sub-samples (if needed) 
• Sub-samples are automatically numbered A, B, C, … and their number is a concatenation with the main sample, like 002A.  

• The Add sub-sample button is active only if the current record is:  

• A sample with no sub-sample. 

• The last sub-sample of a sample, if the bottom depth of the sample has not been reached.  

• Describe the sub-sample and other relevant information.  

 Add a stratigraphic layer 
• Click on Create a stratigraphic layer to add a new layer based on the descriptions of the samples taken.  

• The layer always begins at the bottom depth of the previous layer.  

• The layer ends: 

• At the top depth of the current sample or sub-sample if its Description is empty. 

• At the bottom depth of the current sample or sub-sample if it has a Description. 

• A weighted average of the descriptive elements of all samples and sub-samples found between the top and bottom of the layer 
is used to generated the layer. 

• The button is deactivated if the bottom depth of the current sample is smaller than the maximum depth found in the layers of 
the boring. 

 
 

      The length and type associated to each state 
are specified in the LIST table for the STATE field.  
Values must be R, I, C and G.  
Descriptions are specified as label, type, length 
(in meters).   
If the list is not defined, these values are used: 
R → Remoulded, SS, 0.6096 
I → Undisturbed, ST, 0.6096 
C → Rock core, CR, 1.524 
G → Grab / Manual, GB, 0.3048 
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)  Add in-situ properties for samples and / or sub-samples 

• You can add new properties for samples and subsamples, if not already defined in Geotec as in situ tests or lab tests. 

• Go to Properties table via the Entry forms menu – General tab (see page 7) or by double-clicking on the PROPERTY heading of 
the table at the bottom of the sample entry form. 

• Properties defined are shown at the bottom of the sample entry form.  

• Up to 2 values and 1 remark can be entered per property for each sample and/ or sub-sample.  
Go to Other properties via the Entry forms menu – Lab tests tab - to see all the values entered for your project. 
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 Describe the soils with the matrix  
• Select all descriptive elements.  

• Textual description will be automatically generated as: 
Category. Material (size), gradation, shape, color, oxidation, density /  
consistency, plasticity, moisture, calcareous. Structure. Presence (%)  
(list of debris). Inclusions. Evidence of contamination.  

Category 
• This is the main type of soil or rock. The drop-down list can be edited.  

• The category can be presented in the style file in bold, italic, underline  
and/or capital letters.  

Material 
• Select the proportions of clay, silt, sand, gravel with the option buttons. 

• Or, choose a unique material from the drop-down list. 

Presence, percentage and maximum diameter 
• Add the % of each element in the text field. 

• Check its box to see it in the description.  

Debris 
• Add all debris. Use the type of list “+ description” to add up the debris. 

• Check the box to see them in the description.  

Color, structure, inclusions, evidence of contamination 
• The elements will be added to the description.  

• Use the type of list “+ description” to add up the values.  

Soil characteristics 
• Select 1 or 2 elements per characteristic. They get added to the description.  

• Some items are disabled depending on selections at the top of the matrix.  

• Force Density or Consistency via Cohesionless / Cohesive button at the top.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

      Copy previous to copy information from previous 
record. 
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 1 – After creating the boring, add 
strata 

• Use the list of descriptive tables at the bottom 
of Boring entry form. 

• Or, Stratigraphy button  of horizontal toolbar. 

• Or, use Data > Entry > Stratigraphy. 

• Or, double-click in a stratigraphy column of the 
boring report. 

 2 - Select the Site No and Boring No 
• The lists show the sites and borings defined in 

BORING table. 

 3 – Select the classification type 
• S: Simplified is used to define up to 6 materials constituting the layer. The matrix describes the simplified classification.  

• R: Rock is used to describe manually a rock layer. The rock depth is copied in the ROCK_DEPTH field of the BORING table.  

• T: Text is used to add a remark at any depth without creating a layer.  

• E: End of boring is used to describe the conditions of the end of boring.  

• U: Unified is for the USCS classification (for future use).  

 3 – Enter depths  
• The top depth is always required. It is suggested as the bottom of the previous layer.  

• The bottom depth in only required for types S, R and U.   

 4 – Describe the stratigraphic layer 
• Describe the stratigraphic layer with the soil description matrix via . 

 
 

EN
TE

R
 D

A
TA

 –
 A

LL
 O

TH
ER

 D
A

TA
 There are several other entry forms for soil and  

rock description, in-situ tests and lab tests.  

 1 – Open the entry form  
There are several ways to access entry forms,  
depending on the user’s preferred method. 

• Use the Menu button  of the horizontal  
toolbar or Data > Entry > Entry Forms Menu, 
then click on a button to open its entry form.  

• Or, use the drop-down lists of tables at the  
bottom of the Site, Boring or Sample entry  
form. 

• Or, double-click in a column of the boring  
report that refers to the table (see the  
tooltip shown as you hover over a column). 

 2 - Select the Site No and Boring No and Sample No 
• In the entry form, select the values of the key fields, as appropriate.  

• Enter the relevant data. 

 

      Red buttons 
indicate that data exists 
in the table for the 
current site and boring. 

      Use the automatic creation of 
layers in the Sample entry form to 
generate strata based on the 
descriptions of the samples as selected 
in the soil matrix 
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QUERY and DATA RETRIEVAL 
In all entry forms of Geotec, queries can be done to retrieve data from the database using various criteria. Their purpose is to filter the 
records in the database in order to consult, edit, complete, print or delete them.  

 1 - Enter Query  
• Use  from the toolbar, or [F7], or Query > Enter.  

• Once the mode is changed, the entry form’s  
background is dark blue. 

• The title bar indicates Query mode.  

 2 – Enter Criteria 
Filter values can be entered directly, or via more complex 
specifications.  

• Use [F7] again to fill with last criteria. 

• Use the drop-down lists to select a specific value  
from any field, or hold [Ctrl] or [Shift] to select  
multiple values. 

• Use % as replacement character. 

• Use < or > for numbers or dates. 

• Use IS NULL to retrieve record without a value in the 
field. 

 3 - Execute Query  
• Use  from the toolbar, or [F8], or Query > Execute. 

• The query will return all records corresponding to the specified criteria. 

• If no record corresponds, the entry form returns in New mode (to insert). 

 4 - Cancel Query  
• Use  from the toolbar, or [Ctrl]+[Q], or Query > Cancel. 

• Query is canceled and entry form returns in New mode (to insert). 
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 Adjust depth per page (Log options) 
1- Use from the Log horizontal toolbar, or Style > Options.  
2- Go to Page 1.  
3- Change your vertical distribution values.  
4- Keep a constant scale on following pages if report has more than 

one page. Page 1 can be designed differently than following pages. 

 Print one report 
1- Execute a query to retrieve your boring.  
2- Verify the printer setup via File > Printer Setup. 
3- Verify the margins via Style > Page under Printer tab. 
4- Print with File > Print. 

If a PDF printer is used, file name suggested is 
site_boring.pdf. 
 
 

 Print multiple reports 
1- Execute a query to retrieve all borings to be printed.  
2- Do steps 2 – 4 as for printing only one report. 
3- In the message, select Yes to print all, or No to print 

the current boring.  
If a PDF printer is used, file name suggested is 
site_boring.pdf and there is one pdf per boring  

 
 

The query above will retrieve all records from 
the Boring table where these four criteria apply:   

• The Site number is DEMO  

• The boring was done in 2021 

• The total depth is greater than 10 meters  

• There is no rock depth  
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  Export Data 

You can export the records via any entry form to a CSV file. A CSV file will be created with all records as rows, and all fields as 
columns.  Each header corresponds to the field name in the database. 

1- Open the entry form. 
2- Retrieve your data (via a query). 

3- Use  from toolbar or Action > Export Data. 
4- Select the folder and Save.  

 Import External Data 
You can import values from a CSV file into a  
specific table of the database. Each column must 
have a header corresponding to a field name in  
that table of the database. Each row must contain 
all key fields for that specific table.  

1- Use  from the Log horizontal toolbar.  
Or open the entry form for which data will be  

imported and use  from its toolbar,  
or Action > Import Data. 

2- The window to Import External Data opens. 

3- Verify the table in which data will be imported.  

4- Select a file or a directory with multiple files. 

5- Select your options. 

• Create parent records: creates records in higher hierarchy if not present in the database. 

• Fill empty fields of existing records: updates records already present in the DB, but only for fields that had no value. 

• Replace different values of existing records: updates records already present in the DB, for all values that are different 
between the database and the CSV file. 

• Also import into archived sites and borings: inserts data even if the site or boring in we import is archived. 

6- From the List of files, select one or multiple files to import. 

7- Click Preview to see the results of the data import without executing it. 

8- Verify data with Content of selected file. You may uncheck rows to skip them in the import.  

9- Click Insert. The number of records read, invalid, existing, inserted and modified and number of fields updated are indicated. 
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HOW THE STYLE FILE LINKS TO THE DATABASE 

 Style file 
• It’s the look of the presentation.  The style file is a customizable graphic output independent from projects.  

• Graphs, columns and objects are linked to fields in the database and are presented with user-defined display. 

• Markers (point symbols) and patterns (fill symbols) are used by the style file. 

 Graphs window 
• Use  in the vertical toolbar, or Style > Graphs. 

• Each row represents a column of the boring log. 

• Use the drop-down list in the NAME cell to select the table  
with information to display (from the database). 

• Change the left, width or right value to define its position 
(in mm, with respect to bottom left corner of page). 

• Change its title. 

• All rows are linked to the DEPTH row (#P). 

• Add a FEET or ELEVATION scale if needed. 

• Use Copy and Delete to add and delete columns. 

 Curves window 
• Click Configure in the graphs window, or use  in the  

vertical toolbar, or Style > Legend and curves. 

• Select the column to edit from the preview or the drop-down 
list at the top right. 

• Each row represents which field will be displayed in the  
boring log. 

• Use the drop-down list in the NAME cell to select the field 
to display (from the database). 

• Change the type of display (as Text, Point, Histogram, etc.).  
The Default type is managed by Geotec. 

• Change drawing attributes (colors, fonts, marker symbol,  
etc.) with the button below Delete. 

• Use Copy and Delete to add and delete curves. 

 Axes window 
• Click Axes in the graphs window, or use  in the vertical  

toolbar, or Style > Axes. 

• Select the column to edit from the drop-down list at the top. 

• Select the X-axis and edit the various items. 

• Minimum and maximum values. 

• Primary and secondary divisions. 

• Title, Labels, Gridlines, Tick marks. 

• The Y-axis can also be edited and will show the depth scale. 

 Objects 
• Use in the vertical toolbar, or Style > Object Mode. 

• Use the objects horizontal toolbar to add new objects. 

• Edit any object with a dotted line with a double-click, or  
right click > Properties. 

• Use &&TABLE.FIELD to show the field value or  
@@TABLE.FIELD to show its equivalence. 

• Use $$keyword –> several keywords are suggested by Geotec  
like database, style, current date, logo, etc. 

• Anchor objects (for reports with multiple pages). 

• Add an image linked to a logo file. 

      A tooltip shows 
the name of graph as 
you hover over a 
column in the boring 
report. 
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Log has special displays for several fields with display of Default type.  

 Stratigraphy 
• Each pattern used in the boring report is linked to the type, code and proportion. Examples below: 

• For a Rock with code1 = LMST (limestone), the pattern R_LMST is used. 

• For a Soil with code1 = SMG and proportion = 124 (silty sand, trace gravel), three patterns are superimposed:  
S_S1 (sand) 
S_M2 (silty) 
S_G4 (trace gravel) 
The patterns show the most shapes for proportion 1 and the least for proportion 4. 

• The layer category, primary and secondary materials can be highlighted in the description with italic, bold, ALL CAPS, etc. 

 Samples 
• The STATE is displayed as  for remolded,  for grab,  for unremolded, and  for core.  

• The percentage lost can be represented in black at the bottom of the symbol. 

• The same patterns and description highlight can be shown for samples as for stratigraphy. 

 Piezometers 
• Log schematically illustrates installations with tube, screen, protector, cover, caps. Seals materials and water level can also be 

represented.  

 Limits 
• The plastic limit, natural water content and liquid limit are represented as . 

 Consolidation 
• The lower limit, upper limit and probable preconsolidation stress are represented as . 

 Rock joints 
• ALPHA and DIP of joints can be represented as inclined lines. 

• TYPE of joints can be represented with a symbol specific to the type, inclined by its Beta angle or its Direction, and positioned on 
the X-axis at its Alpha angle or its Dip.  

 Piezocone SBT zones 
• SBT zones can be shown as histograms with their predefined colors representing Zones 1 to 9 of Robertson. 
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CONTACT US 
 

At Sobek, we are committed to providing a technical support that exceeds your expectations. 
Our team of specialists will gladly answer your questions or comments. 

 

Technical Support and Training 
support@sobek-technologies.com 

 

Sales and General Information 
Geneviève Lessard: genevieve@sobek-technologies.com or 514 285-4873 

 

Geotechnical Development 
Ghislain Lessard: lessard@sobek-technologies.com or 514 285-5511 
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