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 1 - Open Lab 
• Use the shortcut on your desktop or launch the program from Geotec\Bin folder.  

 2 – Enter your license identification (LID) provided by Sobek 
• For a trial license, the LID starts with T. 

• For an individual license, the LID starts with W. 

• For a removable license, the LID starts with R. 

• For a network license, the LID starts with N. 

 3 – License and software information 
• From the menu bar, use Help > License. 

The window shows information about the license used. 

• From the menu bar, use Help > About. 
The window shows information about the Geotec version installed. 
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Lab is used to produce graphic reports for laboratory tests done on aggregates, both detailed reports for each test or summary 
reports for your projects. The reports are produced with the data available in the corporate database. See the Tutorial on Log for 
information about the definitions, graphic interface, characteristics of entry forms and data entry. 

 Database and data hierarchy 
• The database is the file in which data is saved. The database contains all sites, borings, samples, laboratory tests, etc.  Centralize 

all your data in one corporate database. 

• The Geotec databases have a normalized structure of tables, fields and relationships between the tables – no table or field 
definition is done by the user. The databases are created via the DBM module. 

• Each laboratory test is defined by its site-boring-sample combination, which must be unique in the database. 

 

 Style file 
• This is the look of the presentation.  The style file is a customizable graphic output independent from projects.  

• Typical style files include one or multiple graphs as well as tables. 

• Style files can be created for summary reports with multiple curves, for summary report for one test only, or for detailed report 
for validation in the lab.  

 Entry forms 
• Entry forms are integrated in all modules of Geotec to enter, modify, delete and view data. Entry forms include calculations, 

validations, default values and automations. 

• Entry forms and calculations are available for the Grain size analysis and Hydrometer test, Atterberg limits and natural water 
content, Proctor test and Consolidation tests.  

• Entry forms are also available for these lab tests: Swedish cone, specific gravity, density, unconfined compression, shear strength 
and concentrations of contaminants.  

• Entry forms are used to retrieve data based on various criteria via the Query mode.   
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      Lab can be used in English 
or in French. Change the 
language via the Style menu.  
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 1 – Connect to the database 
The database is the file in which data is saved. The same data can be used via  
any Geotec modules.  

• Use  or File > Open Database to open an Access or db3 database.  

• Use  or File > Connect Database to connect to an SQL Server or Oracle 
database and enter the username, password and ODBC connection alias  
provided by your IT. 

• If you are doing a trial, open Geotec_tutorial.mdb in folder \Geotec\Access. 

• The title bar shows the software name and the connected database  
between brackets as [DBMS: File] (Database version - Language).  

 2 – Open a style file and logo 
To validate the inputs and results more easily, open a style file designated for lab test (grain size, limits, etc.). Add your logo to your 
report.  

• Use  or File > Open Style to select another style file created via Lab. Several are provided with Geotec. 

• Use File > Recent Logos and select a row to open your logo file. Make sure an image identified as $$logo exists (see Objects and 
content tables on page 11). 

 3 – Enter laboratory management data 
The laboratory management data are defined once and saved in the database. They are specific to the lab and can be used for any 
project and any test done.   

• Use Menu button  of the horizontal toolbar or Data > Entry > Entry Forms Menu. 

• Go to Lab tests tab 

• Click the buttons under Laboratory Management 

 4 – Define samples if necessary 
Each laboratory test is associated to a sample, which is defined by its site number, boring number and sample number. Verify that 
the sample already exists in the database, or define it. 

• Open the Sample entry form via button  of the horizontal toolbar.  

• Use  from the toolbar, or [F7], or Query > Enter.  

• Select the site number from the list. You can also select the boring number from the list to filter more.  

• Use  from the toolbar, or [F8], or Query > Execute. 

• All samples defined for the site (and boring) are retrieved. Use the big arrows     to navigate through the samples.  

• If the sample is not defined, add a new one with . You may need to add the site and / or boring if not already defined in the 
database. See the Tutorial on Log for a step-by-step of data entry.  

 5 - Enter laboratory test data 

The laboratory test entry forms are opened via buttons     of the horizontal toolbar, or Data > Entry > 

•  for Grain Size 

•  for Proctor 

•  for Consolidation 

•  for Atterberg Limits 

 

💡 Include the connection string in your shortcut to 
automatically connect to the last database used. 
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The sieving methods used in the laboratory and associated sets of sieves can be defined in  
the database. The sieving method used is selected for each grain size analysis.  

• Use Menu button  of the horizontal toolbar  
or Data > Entry > Entry Forms Menu. 

• Go to Lab tests tab 

• Click Sieving methods 

• You can view existing methods via a query with 

buttons   ([F7]) and  ([F8]).  

To add a new method, click . 

• Enter the sieving method (typically the  
number of the standard).   

• Up to 2 separations can be defined (3 groups  
of sieves).  

• For each applicable fraction, indicate the  
weighing method and the unit.  

• In the table, add each sieve diameter (in mm)  
and indicate to which fraction it corresponds:  
Q for cobbles or coarse fraction, G for gravel or  
medium fraction, and S for sand or fine fraction.  

• Save the method with  and add another one  
if applicable.  
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Grain size specifications can be associated with grain size tests. The compliance at each diameter 
where there is a requirement is calculated by Geotec. The specification can also be shown visually 
on the report.  

• Use Menu button  of the horizontal toolbar or Data > Entry > Entry Forms Menu. 

• Go to Lab tests tab 

• Click Grain size requirements 

• You can view existing requirements via a query  

with buttons   ([F7]) and  ([F8]).  

To add a new specification, click . 

• Enter the envelope number. 

• In the table, indicate the diameter (in mm)  
where a requirement applies. 

• Enter the minimum and maximum passing for 
each diameter.  

• Save the specification with  and add another  
one if applicable. 
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Hydrometers used in the laboratory are calibrated. Their calibration factors are used in the calculations for the hydrometer test.  

• Use Menu button  of the horizontal toolbar or Data > Entry > Entry Forms Menu. 

• Go to Lab tests tab, then Hydrometer calibrations 

• You can view existing hydrometer calibrations via a query with buttons   ([F7]) and  ([F8]).  

To add a new hydrometer calibration, click . 

• Enter the hydrometer number, the hydrometer model (151H or 152H) and the last calibration date.  

• Enter the length, volume and coefficients A and B of the calibration curve.  

• Enter coefficients A and B of composite correction curve. 

• Enter density correction.  

• Save the hydrometer calibration with  and add another one if applicable. 

 

      You can add sieving methods  
BNQ 2501-025 and LC 21-040 via DBM.   

      You can add grain size 
specifications MG-20, MG-20B, 
MG-56 and MG-80 via DBM.   

      You can add the default 
calibration values for ASTM 151H 
and 152H hydrometers via DBM.   
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 Calibration curve 
It establishes the relationship between the distance (cm) and the reading taken on the hydrometer, at the top of the meniscus.  

• The measured depth L1 is the distance from the reading mark on the hydrometer stem to the top of the hydrometer bulb. 

• The real depth H is the distance from the reading mark on the hydrometer stem to the geometric center of the hydrometer 

bulb, or 𝐻 = 𝐿1 +
𝐿𝐵

2
 

• The effective depth H' is the real depth corrected for water displacement resulting from the insertion of the hydrometer in the 

suspension, or  𝐻′ = 𝐻 −
𝑉𝐵

2𝐴
= 𝐿1 +

𝐿𝐵

2
−

𝑉𝐵

2𝐴
    

where VB is bulb volume (cm3), A is sedimentation cylinder area (cm2), LB is bulb length (cm) and L1 is measured depth (cm).  

The different sets of values can be used as calibration. Below 
are the coefficients to enter for the example of the figure. 

• If measured depth is used for calibration (blue line), enter 
coefficient A (-0.167), coefficient B (10.6), bulb volume (64 
cm3 in our example) and bulb length (14 cm). 

• If real depth is used for calibration (orange curve), enter 
coefficient A (-0.167), coefficient B (17.6), bulb volume (64 
cm3 in our example) and bulb length of 0 (included in 
calibration). 

• If effective depth is used for calibration (gray curve), enter 
coefficient A (-0.167), coefficient B (16.485), bulb volume of 
0 (included in calibration) and bulb length of 0 (included in 
calibration). 

 Composite calibration 
It is used to adjust for inaccuracies from the use of a dispersing agent, from hydrometers calibrated at 20oC and from readings at the 
top of the meniscus.   

Prepare a solution of distilled water and dispersing agent in the same proportion as will be used in the sedimentation tests. At 2 
sufficiently different temperatures, read the hydrometer at the top of the meniscus. For a 151H, the correction is the difference 
between the reading and one. For a 152H, it is the difference between the reading and zero. Create a graph of correction with 
temperature and set a straight-line relationship with equation y = Ax + B.  

If composite calibration is not done, set A and B coefficients to 0. The correction will be entered by the user for each measurement. 

 Density correction factor 
The correction factor F for density is used in the BNQ 2501-025 standard. Please refer to it. With a value of 1, the factor has no 
impact. 
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Lab equipment can be defined in the database. This ensures better monitoring in the event 
that an equipment is faulty, and speeds up the entry of equipment information such as 
dimensions. 

• Use Menu button  of the horizontal toolbar or Data > Entry > Entry Forms Menu. 

• Go to Lab tests tab 

• Click Lab equipment 

• You can view existing equipment via a query 

with buttons   ([F7]) and  ([F8]).  

To add a new equipment, click . 

• Enter the category. This is used to create field-
specific drop-down lists in the entry forms. 

• Enter the apparatus number. 

• Enter all relevant information for each 
equipment (mass, volume, area, etc.). 

• Save the equipment with  and add another 
one if applicable. 

      These equipment categories are 
supported: 
BALANCE CYLINDER TARE 
RAMMER MOULD SIEVE 
THERMOMETER 
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The lab measurements and results of grain size analysis are calculated in the Grain Size entry form.  

• Open a style file showing grain size results via File > Open Style. 

• Use Grain size button  of the horizontal toolbar or Data > Entry > Grain Size. 

• You can view existing grain size test via a query with buttons   ([F7]) and  ([F8]).  

• To add a new test, click . Select the site number, boring number and sample number on which the test was done.  

• Select the sieving method used. The diameters 
defined in the sieving method are automatically 
generated in the bottom table.  

• Select a specification if applicable.  

 

 Sieving 
Geotec will calculate the grain size curve based on 
sieving measurements.  

• Click on Sieving tab at the top.  

• Enter the total mass of soil for each fraction. 
The fractions and the minimum and maximum  
diameters are defined in the sieving method.  

• Enter the mass after washing to calculate the 
loss percentage for test validity.  

• Only if the test was done on wet soil, enter the 
auxiliary water content. Otherwise, leave 
empty.  

• For each diameter, enter the individual or 
cumulative mass (defined in sieving method).  

• Calculate results with . 

• Go to the Results tab to view the passing 
percentages at each diameter (bottom table) 
and various results calculated by Geotec.  

 

 Hydrometer 
Geotec will calculate grain size curve and include 
the sedimentation analysis.  

• Click on Hydrometer tab at the top.  

• Select the hydrometer and cylinder used. See 
hydrometer calibrations. 

• Adjust the specific gravity.  

• Enter the sieve diameter. Geotec retrieves the 
corresponding passing percentage.  

• Enter the dry mass of the sample. You can use 
the dry mass calculation.  

• In the bottom table, enter the hydrometer 
reading and the temperature at corresponding 
times (in minutes). If a measurement was not 
taken at a certain time, skip it.  

• If the composite correction coefficients are 0, 
enter the reading correction. Otherwise, it is 
calculated by Geotec.  

• Calculate results with .  

• Go to the Results tab to view the passing 
percentages at each diameter (bottom table) 
and various results calculated by Geotec.  
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If passing percentages at each diameter are  
already calculated (for both sieving and  
hydrometer test), it is possible to enter them  
directly without the lab measurements.  

• Go to Results tab 

• In the bottom table, enter the passing  
percentage at each diameter, starting at 100%. 

• Calculate results with . 
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The lab measurements and results of water content and liquid and plastic limits tests are calculated in the Limits entry form.  

• Open a style file showing limits results or an Atterberg chart via File > Open Style. 

• Use Limits button  of the horizontal toolbar or Data > Entry > Atterberg Limits. 

• You can view existing limits via a query with buttons   ([F7]) and  ([F8]).  

• To add a new test, click . Select the site number, boring number and sample number on which the test was done.  

 Natural water content 
• Click on Water content tab in the table. 

• Enter the tare mass, tare + wet soil mass 
and tare + dry soil mass. Water content 
gets calculated.  

• Add another row (I_POINT of 2, 3, etc.) if 
more than one measurement is done on 
the same sample.  

• The water content in the Results gets 
calculated by Geotec.  

 Plastic limit 
• Click on Plastic limit tab in the table. 

• Enter the tare mass, tare + wet soil mass 
and tare + dry soil mass. Water content 
gets calculated.  

• Add another row (I_POINT of 2, 3, etc.) if 
more than one measurement is done on 
the same sample.  

• The plastic limit in the Results gets 
calculated by Geotec.  

 Liquid limit (Casagrande) 
If the liquid limit test was done with the 
Casagrande apparatus…  

• Click on Casagrande tab in the table. 

• Enter the tare mass, tare + wet soil mass and tare + dry soil mass. Water content gets calculated.  

• Enter the number of blows.  

• If doing the multipoint method, add another row (I_POINT of 2, 3, etc.)  

• The liquid limit in the Results gets calculated by Geotec where N = 25 or via the one-point method equation.  

 Liquid limit (Swedish cone) 
If the liquid limit test was done with the Swedish cone…  

• Click on Swedish cone tab in the table. 

• Enter the tare mass, tare + wet soil mass and tare + dry soil mass. Water content gets calculated.  

• Enter the penetration readings P1 to P4. It is also possible to enter the initial reading P0.  

• The average penetration is calculated by Geotec. P0 is subtracted from Px if entered.  

• If doing the multipoint method, add another row (I_POINT of 2, 3, etc.)  

• The liquid limit in the Results gets calculated by Geotec where P = 10 or via the one-point method equation.  

 Results  
If the values of water content, plastic limit and liquid limit are already calculated, it is possible to enter them directly without the lab 
measurements.  

• Go to Results section. 

• Enter the values.  Plasticity index and liquidity index are calculated by Geotec.  

• Click on to calculate the USCS.  
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The lab measurements and results of Proctor tests are calculated in the Proctor entry form.  

• Open a style file showing Proctor compaction results via File > Open Style. 

• Use Proctor button  of the horizontal toolbar or Data > Entry > Proctor. 

• You can view existing Proctor tests via a query with buttons   ([F7]) and  ([F8]).  

• To add a new test, click . Select the site number, boring number and sample number on which the test was done.  

 Lab measurements 
• Select the test method. Passing % 

is calculated by Geotec from the 
grain size curve done for the same 
sample.  

• To apply a normalizing correction 
at 5 mm, select the correction to 
use. A retained % on 5 mm must 
also be entered for each point.  

• Select the rammer and mould 
number. The mould mass and 
volume are used in calculations.  

• Adjust the specific gravities.  

• In the bottom table, enter the tare 
mass, tare + wet soil mass, tare + 
dry soil mass and mould + wet soil 
mass. Water content and density 
get calculated.  

• Enter the mass retained on 5 mm, 
if measured. The corresponding % 
gets calculated.   

• Add another row (I_POINT of 2, 3, 
etc.) for each point of the curve.  

• Calculate results with .   

• The optimum water content and 
maximum dry density for the test 
are calculated.   

• The optimum corrected for stone 
content is calculated and differs only if % passing is less than 100%.  

 Results  
If the values of water content and density for each point of the curve are already calculated, it is possible to enter them directly 
without the lab measurements.  

• Go to the bottom table. 

• Enter D and W values.  

• Click on to calculate the optimum and other results as described above.  
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The lab measurements and results of consolidation tests are calculated in the Consolidation entry form.  

• Open a style file showing consolidation results via File > Open Style. 

• Use Consolidation button  of the horizontal toolbar or Data > Entry > Consolidation. 

• You can view existing consolidation tests via a query with buttons   ([F7]) and  ([F8]).  

• To add a new test, click . Select the site number, boring number and sample number on which the test was done.  

 Consolidation test 
The Casagrande construction is used for the 
calculations.  

• Enter the in-situ effective stress P0. 

• Select the calculation method. Sobek is the 
simplified method, MTQ follows the LC22-301 
standard.  

• In the bottom table, enter the pressure and 
the void ratio for each point (I_POINT). 

• Add rows for the entire consolidation curve. 

• The compression index per loading is 
calculated (CC).  

• Calculate results with .   

• The voids radios, effective stress at end of 
testing and Pc min, Pc, Pc max and coefficients 
are calculated.  

• Cv is not calculated in this version.  

 Permeability test 
If an odometer permeability test was done 

• Enter the permeability in m/s at different 
loadings.  

• Click on to calculate the Ck coefficient. 
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REVIEWING REPORTS and PRINTING 

In all entry forms of Geotec, queries can be done to retrieve data from the database using various criteria. Their purpose is to filter the 
records in the database in order to consult, edit, complete, print or delete them.  

 Retrieve information and view graphic output 
To review a report: 

• Open the desired style file (look of the presentation) via 

 or File > Open Style. Several examples of style files 
are available in the \Style folder of Geotec.  

• Open the entry form of the specific lab test with 

buttons    , or the Sample form with . 

• Use  from the toolbar, or [F7], or Query > Enter.  

• Enter the criteria for filtering. It can be the site number 
and / or the boring number, a specific management 
information, etc. See section QUERY and DATA 
RETRIEVAL in the Tutorial on Log for more details.  

• Use  from the toolbar, or [F8], or Query > Execute. 

• All records that correspond to the criteria entered are 
retrieved and their graphic output shown. Use arrows 

    to navigate through the records.  
 

 Define display and printing options 
Options are available in Lab to define the display mode after queries, the batch printing 
parameters and the samples to include in summary tables.  

• Click  in the Lab horizontal toolbar, or Style > Options and go to General tab. 

• Use the first two options to define which curves from the query are displayed in the graph. 

• With display all selected curves, all curves retrieved are shown at once in the graph.  
When navigating through the records, if grouped by sample, each curve is highlighted in red one by one. If grouped by boring, all 
curves from the same boring are highlighted in red. Same logic for grouped by site.  

• With display current curves, only the curves 
corresponding to the current group are 
shown.  
If grouped by sample, one curve at a time is 
displayed. If grouped by boring, all curves 
from a boring are shown. Same logic for 
grouped by site. You can navigate through the 
records. 

• If summary tables are shown in the style files (see 
editing the style files), decide which samples to 
include in the tables.  

• If summary tables are shown, order the samples from top to bottom by number or by depth. 

• For batch printing, enter the maximum number of samples per page.  
 

 Printing 
To print a report… 

• Execute a query to retrieve your graphic report(s) 

• Verify the printer setup via File > Printer Setup 

• Verify the margins via Style > Page under Printer tab 

• Print with File > Print. If a PDF printer is used, file name suggested is site_boring_sample.pdf. 

• If printing multiple files at once (batch printing), in the message, select to print everything on one page (Same), or on multiple pages 
based on the maximum number of samples per page (Groups).  

 

      The query above will retrieve all grain 
size records where these criteria apply:   

• The Site number starts with DEMO  

• The specification associated is MG-20. 

      To batch print, 
select all selected 
curves in the options.  
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EDITING THE STYLE FILES 

The look of the presentation is saved in the style file, which can be reused for any project.  In Lab, style files typically include one or multiple 
graphs as well as summary tables, test tables and objects or tables of content. Example style files can be found in the \Style folder of Geotec. 

 Graphics 
A graphic output can be added to show: the grain size curve, 
Proctor curve, consolidation curve, permeability curve, Atterberg 
chart, Houston-Mitchell chart, or liquid limit charts to determine 
liquid limit.  

• Use  in the vertical toolbar, or Style > Graphs. 

• Add a row with number between 1 and 99 and #P of 0.  

• Select the graph name from the NAME column.  The 
configuration is automatic based on the graph selected.  

• Define its position with left, width, right, top, height and 
bottom (in mm, with respect to bottom left corner of page). 

• The limits and formatting of the X and Y axes can be 
customized via the Axes button.  

 Summary tables 
Up to 3 tables of results can be added in the style file, as well as a 
CLASSIFICATION table, for grain size curves. The tables will be 
filled with information related to each curve displayed in the graphic.  

• Follow the same steps as for graphics to add them and define their position (see above).  

• Set their number between 100 and 199.  

• Click  in the Lab horizontal toolbar, or Style > Options to edit their configuration.  

• Go to Classification tab to define the maximum diameters and label of the main and secondary soil divisions (for grain sizes) 

• Go to Table x to configure the columns of each table.   

• Select the table and field to display from the Geotec database – it can be from any table related to sample 

• Add the heading label and set the width proportion 

• Results specific to the test can also be selected from the Table and Field cells.  

 Detailed test tables 
Tables showing detailed test data can also be added for 
validation.  

• Follow the same steps as for graphics to add them and define 
their position (see above).  

• Set their number between 100 and 199.  

• Select the table from which data will be presented from the 
drop-down list.  

• Via Configure, edit the fields to present by Hiding the 
unnecessary ones.  

 Objects and content tables 
Add objects or content tables to show information specific to the 
sample shown.  

• Use in the vertical toolbar, or Style > Object Mode. 

• Use the objects horizontal toolbar to add new objects. 

• Edit any object with a dotted line with a double-click, or right 
click > Properties. 

• Use &&TABLE.FIELD to show a field value or $$keyword to show a keyword suggested by Geotec like database, style, date, etc. 

• Add an image linked to a logo file. 
 
Content tables are objects formatted as tables, with defined columns and specified number of rows. 

• In Object mode, click Create a table, and draw with the mouse where the table will be positioned. A table with #300 and up is created. 

• Add the content, with columns separated by a semi-colon.  

• Edit the number of rows to show.  

• Via Configure or in Object mode, edit each column heading and width. 

      For grain sizes, 
SECOND_AXIS can be added to 
show passing and retained %. 
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CONTACT US 
 

At Sobek, we are committed to providing a technical support that exceeds your expectations. 
Our team of specialists will gladly answer your questions or comments. 

 
Technical Support and Training 
support@sobek-technologies.com 

 

Sales and General Information 
Geneviève Lessard: genevieve@sobek-technologies.com or 514 285-4873 

 
Geotechnical Development 

Ghislain Lessard: lessard@sobek-technologies.com or 514 285-5511 
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